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WELCOME TO SEWCAT© 
EMBROIDERY FILE CATALOG SOFTWARE 

 
SewCat (© S & S Computing, Inc) is software that allows you to organize your 
embroidery files into catalogs. These catalogs can be either virtual folders (which are 
stored temporarily in computer memory and later saved to disk as a very small database 
file) or actual directory folders on your hard drive or removable media. SewCat allows you 
to easily view the stitch patterns encoded in your embroidery files, making it easy to sort 
and optionally rename files in meaningful ways. The virtual cataloging that SewCat 
performs leaves your original embroidery files undisturbed. This is in contrast to the 
Explorer cataloging option which reorganizes files into folders on your hard drive.  
 
There are several advantages to each form of cataloging. In creating virtual catalogs, any 
mistakes – such as inadvertent file or folder deletions – are not permanent and the 
original embroidery files are never altered or deleted. Second, when a virtual catalog is 
saved to disk, it takes up very little space. This allows you to create several different 
catalogs (with different themes, for example) containing the same files, while occupying 
(almost) no additional disk space. However, a disadvantage of the virtual catalog 
(compared with a real catalog) is that only links to the cataloged files are saved. Thus, if 
you change the location on your hard drive, or remove the external media (CD or floppy) 
containing the cataloged files, those files will no longer be viewable when you reopen the 
saved catalog file. In the Explorer (or real) catalog mode, the catalog folders are created 
on your hard drive and the files you move around (either by copying or moving them with 
your mouse) are actually saved on the hard drive. Thus, they will occupy additional space 
on the hard drive, but since there are no virtual links, you will always be able to view the 
catalog folder contents. SewCat gives you the choice of using virtual or real catalogs, 
depending on your needs. 
 
Below is a quick start summary of the features and functionality available with SewCat. 
It is, however, recommended to read the short user’s guide that follows the summary, to 
get an in-depth description of the various SewCat features. Starting with v1.32, 
embroidery files that are compressed in Zip archive files can be viewed and cataloged by 
SewCat. Zipped files appearing in the icon view pane will be marked with an asterisk (*). 
 

SewCat Feature Summary 
Open files to view for cataloging 
In the directory list (left) panel, click the “+” with the left mouse button ( ) to expand (open for viewing) a 
directory and click the box to view any embroidery files in that directory or its immediate child folders. Icons 
of embroidery patterns contained in the selected files will appear in the central view (or icon) panel. Clicking 
the “-” will collapse that branch of the directory tree. Clicking a checked box will remove the check mark and 
the central panel view will no longer display icons for the files in unchecked directories. 
 
Open a previously saved catalog 
From the File menu, click the Open option. 
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Save a catalog 
From the File menu, click the Save, or Save As, option. Starting with v2.75, this will also save a copy of the 
state of the left-panel directory tree. When the catalog is re-opened, the directory tree will also be restored 
to its prior state. 
 
Select files to move into the catalog 
Click with the left mouse button the icon(s) in the central panel that you wish to move. This will select the 
associated files and a selection rectangle will be drawn around them. Hold down the Ctrl or Shift key to 
select multiple icons for moving. Clicking in the area outside any of the icons will clear the icons previously 
selected. This left-button behavior is similar to that of Windows Explorer. 
 
Display a resizeable view of a single file 
Double-click (with the left mouse button) the file icon in the middle pane OR single-click the catalog pane 
file icon to show a resizable view of the stitch pattern. You can resize the viewing pane by click-dragging the 
resize bars around the pattern view. If the file can not be found in the path stored in the catalog (this can 
happen if the file has been moved or deleted since the catalog was created), then a message related to this 
“orphaned” file will be displayed. 
 
Move files into the catalog 
After selecting the icon(s) to move, hold down the left mouse button (while the mouse cursor is over one of 
the selected files) and drag the file into the right catalog panel Release the mouse over the catalog folder 
and drop the file(s) into the target folder. 
 
Add catalog folders 
Select (left-click) the folder where you want to add the new folder. Press the Insert key or click the Edit 
menu, Insert item. You may also click “Import Folders” on the Tools menu to add folders (just the folders – 
not the files in them) that are selected in the left panel directory tree. This is a time-saving way of adding 
lots of folders very easily. 
 
Delete catalog files and folders 
Select (left click) the file or folder to delete. Press the Delete key or click the Edit menu, Delete item. 
 
Rename catalog folders and files 
Select (by clicking the left mouse button) the catalog folder or file to rename. Then, left click the text label 
to the right of the folder (file) icon. Edit the text and press either Return (Enter) to accept the new text or 
Escape to restore the original text. 
 
Edit path to catalog folders and files 
If you have moved your folders to a different drive (with a different drive letter), then you can update the 
Virtual Catalog by using the Edit menu/VC Drive menu item. This opens a dialog box where you may select 
(by clicking the left mouse button) the drive to rename. Then, left click the text label and edit the text. Press 
either Return (Enter) to accept the new text or Escape to restore the original text. 
 
Alphabetize catalog folders and files 
Select the “Alphabetize” item from the “Tools” menu. 
  
Zoom the center panel icons 
From the View menu, click the Zoom Icons item and set its value (100% is the default, no zoom state). 
Zoom factors larger than 100% will magnify the icons in the center panel, while factors less than 100% will 
reduce their on-screen size. Use the toolbar (+/-) to expand or contract the icons by increments of 1%. 
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Enlarge the folders in the catalog 
From the View menu, click the Large Catalog Folders menu item. To restore the original size, click this item 
again. 
 
View file details for all icons in center panel 
From the View menu, click the File Details menu item. Use the Units menu item to toggle between American 
and metric units. 
 
Restrict (Filter) the Types of Embroidery files shown in the center panel 
From the Tools menu, click the File Filter menu item. Hold down the Ctrl or Shift key to select multiple 
filters.  
 
Resize the panels 
From the Window menu, click the Resize menu item. This will display resize handles on the separator 
between the directory panel and the icon view panel. Move this separator to resize the directory and central 
panel. Alternatively, simply click (with the left mouse button) on either the left or right separators and drag 
them to resize the respective panel extents. 
 
Perform a Keyword File Search 
From the Tools menu, click the Keyword Search option (or press the “w” toolbar button). Enter the name(s) 
to use to filter the embroidery files that will appear in the icon panel. 
 
Associate Keywords With a Virtual Catalog File 
Right-click a file in the virtual catalog. This will display a dialog for adding or modifying keywords for that 
specific file. Do not hold down the Shift or Ctrl key for this operation. 
 
Add a Prefix or Suffix to a Group of Catalog Files 
Left-click the first file in the group. Then holding down the Shift key (or the Ctrl key), right-click the last file 
to define the group. A dialog will appear for entering a prefix or suffix that will be added to the display 
name of the selected group of files in the Virtual Catalog. 
 
Toggle between Catalog and Explorer views 
From the View menu, click the Catalog/Explorer option. 
 
Find the original file path for a file in the Catalog 
Click on the catalog file. The full path of the original file on the hard drive (or other media) will be displayed 
in the bottom Status Bar. Double click the catalog file to see an enlarged icon view of the pattern in the 
lower right of the Virtual catalog pane. 
 
Find the location in the Catalog of a file on disk 
If the file on disk (shown in the middle panel) has been catalogued, a check-mark will appear under it. You 
can right-click on the middle-pane file icon to pop-up a list of all the locations in the Virtual catalog referring 
to that disk file. You can select (with the left mouse button) one of the list items to automatically expand 
the Virtual Catalog list to show the selected file. 
 
Preview all files in the Catalog 
Be sure the View/Catalog menu option is checked. Then click the catalog directory check-boxes besides the 
catalog folders whose content is to be viewed. All the files in the checked catalog folders will be displayed in 
the central view panel. Use this in conjunction with the File/Print Album menu to print an album of the 
selected catalog folders. To return to viewing the left-pane directory files, simply click one of the left panel 
check boxes. 
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Print this manual 
When there are no icons in the central panel (this manual is visible), click on Print Manual in the File menu. 
 
Print album of icons 
When the central panel displays icons of the files you want in the album, click on Print Album in the File 
menu. The album can contain files from the directory tree, or from the catalog (if the View menu item 
Catalog Icons is checked). 
 
 
Starting a SewCat Session 
 
To begin a new SewCat catalog, use the directory folder list appearing in the left panel to 
navigate through your directories and locate embroidery files to be cataloged. Click the 
“+“ symbol next to the directory folder you wish to open and an expanded directory will 
appear together with its subdirectory (child) folders. (Important: the terms “click” and 
“select with the mouse” mean to use the left mouse button. Right mouse button clicks 
are generally not used in SewCat.) Click the check box to display icons of the embroidery 
files contained in that folder and all its subdirectories. Uncheck the box (by clicking it 
again) to hide the file icons for that folder and its subdirectories. To close (collapse) a 
branch of the directory tree, click the “–“ symbol next to it. This will not affect the display 
of icons in the middle panel. 
 
When you have checked the box of a directory containing embroidery files, images 
(icons) of the patterns contained in those files will appear in the center (viewing) panel. 
The file name is shown above each icon. An asterisk after the file name indicates it is 
contained in a Zip archive. To show more details about the files, click the File Details item 
in the View menu. To change the displayed size of the icons (zoom), select the Zoom 
Icons item in the Tools menu or click the “+” or “-” button on the toolbar. If necessary, a 
vertical scroll bar will automatically appear on the right of the center panel, as well as a 
horizontal scroll bar at the bottom of the panel. Click the scroll bar button to activate 
scrolling in the central panel. Dragging the scroll bar, or using the Page Up, Page Down, 
Home or End keys, will allow you to view all the icons in the opened folder. You can limit 
(filter) the files appearing in the icon view by selecting the “keyword” option from the 
Tools menu. Enter a single keyword (or a comma-delimited list of keywords) which will be 
used to display only those embroidery files which contain at least on of the keywords in 
their name. 
 
 
Storing Files in Catalog Folders 
 
The catalog appears in panel on the right of the SewCat workspace. It initially contains a 
few sample folders to demonstrate what a catalog might look like. You can delete these 
folders, or rename them to something more suited to your application (see the discussion 
below on manipulating folders for more details). 
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Use the mouse to select files from the center panel (by left-clicking on the file icons). 
Once selected, drag and drop the icon(s) into the catalog directory tree. Multiple files can 
be selected by holding down the Ctrl or Shift key during selection. An icon will appear with 
a thickened border when it is selected. After is is dropped into the catalog, a box with a 
check mark will appear below the icon to indicate it has been inserted into the catalog. 
This behavior is modeled after the folder selection logic of Windows Explorer®. Note that 
you can clear the selection status of all files by clicking on any blank area in the middle 
pane. 
 
 
Interaction of SewCat With Other Applications 
 
You can also drag and drop files from the center panel or from the catalog into another 
application, such as an embroidery editor (SewWhat!©, for example) or Windows 
Explorer. For example, by opening both SewWhat! and SewCat, you will be able to drag a 
file from the Catalog (or the center panel) and drop it into the SewWhat! workspace. If 
the SewWhat! workspace is empty, this will automatically open a new editing pane with 
the dropped file appearing in it. If there already is a file in the SewWhat! editing pane, 
then the dropped file(s) will be merged with the existing file. This may be used, for 
example, to combine alphabetical characters (such as monograms) with pictorial sewing 
patterns. 
 
 
Manipulating Catalog Folders 
 
Important note: at present these operations can not be reversed through the Ctrl-Z Undo 
key combo. Therefore take special care when Deleting files or folders from the catalog. 
 
To create a new folder in the catalog, first click on the catalog folder that will be the 
parent of the inserted folder. (The new child folder will go below its parent.) Then press 
the Insert key. This works for both top-level folders and subdirectories. New folders can 
also be added to the Virtual Catalog by clicking on the Tools Menu Import Folders item. 
This latter method will allow you to insert empty folders into the virtual catalog based on 
the folders that are selected in the directory view. This is a quick way to populate your 
Virtual Catalog tree. 
 
To delete a folder (and all its contents) or a file from the catalog, first select the folder or 
file (by clicking it) and then press the Delete key. Files and folder in the catalog can also 
be moved to another branch of the catalog (dragged and dropped) or copied (hold down 
the Shift key during the mouse drag to copy the folder to a new location).  
 
An existing catalog folder or file may be renamed by first clicking on the appropriate icon 
to select (highlight) it. Next, click the label (the text next to the icon) to initiate text-
editing mode. (This is important: simply clicking the file or folder will not put you into 



 6

editing mode! You must click the text label, too.) Once in editing mode a box will appear 
around the text to be edited, which should now be highlighted and blinking. After you 
complete the text editing, press either Return to accept your changes, or Escape to 
recover the original text. This will exit text-editing mode. 
 
To view an enlarged image of any cataloged file, along with some pattern details 
(stitches, colors, size), click on the file icon or label in the catalog. 
 
Selecting the Save As item from the File menu will allow you to choose a name and 
location for saving the catalog to a small SewCat catalog file (*scc extension). This file 
stores the information required to restore your virtual catalog in the future. It contains 
only the names and locations of the embroidery files in your catalog and the associated 
embroidery files on disk. It does not store any stitch data.  
 
From the View menu, choose the Icon Size option to change the size of the folder icons 
appearing in the catalog. 
 
 
Restoring a Catalog from a File 
 
Another way to begin a SewCat Session is by opening an existing embroidery catalog file 
saved from a previous editing session. From the File menu select Open and choose the 
catalog from a list of available catalog files. Note that the catalog files you create with 
SewCat are virtual directories. That is, they are stored in small catalog files and appear in 
the SewCat catalog panel, but they do not actually modify the contents of your disk 
directories. Thus, deleting files and folders in the catalog tree has no impact whatsoever 
on the embroidery files you have stored on disk. This makes the virtual cataloging system 
a very safe and user-friendly way of organizing your embroidery files. 
 
 
Printing Albums and the SewCat Manual 
 
It is possible to print an album of the file icons appearing in the center panel. To do this, 
select Print Album (or Print Preview) from the File menu. If there are no files open for 
viewing, then this help manual can be printed by selecting Print Manual instead. The 
album icons can be either those associated with the directory (left) panel or the catalog 
(right) panel, depending in which directory tree the last check-boxes were selected. 
 
 
Creating a Permanent Catalog: organizing embroidery folders on your hard 
drive 
 
There may be situations when you want to create permanent catalogs directly on your 
hard drive (in contrast to producing the virtual catalogs described above). SewCat allows 
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you to do this by choosing the Catalog/Explorer item on the View menu. An explorer-style 
directory tree will appear in the right panel overwriting the virtual catalog (which is stored 
temporarily in memory – be sure to save it before exiting SewCat). All the embroidery files 
stored on your various drives (floppies, hard drives, CD’s, USB media) can now be viewed 
in the Windows Explorer-like right panel. You may drag/drop files from the center icon 
panel into this Explorer panel. Now the files you add will be permanently stored on the 
physical media (hard drive, floppy or Zip disk) you drop them onto. In contrast to virtual 
catalogs - which do not modify your disk contents - moving files and deleting folders in 
the Explorer panel will change the files and directories on your drive(s). The result is 
exactly the same as using Windows Explorer to rearrange your files and 
folders. The user should be aware of this important difference between the SewCat 
Virtual Catalog and Explorer functionality. 
 
 
Additional Special Features 
 
There is now a “Refresh Tree” button in the Directory View (left) panel. This button may 
be pressed if, while a SewCat session is open, files or folders are added to or deleted from 
one of the drives displayed by SewCat. This will update (“refresh”) the SewCat directory 
tree to display those changes without having to close the active session. 
 
From the “View” menu, you can select various features to control the display of icons in 
SewCat. 
 

Jump Stitches: check this item if you wish to display view jump stitches in the 
enlarged right-panel icon view. 
Texture: check this item to display a textured view of the icon in the bottom right 
panel. 

 
From the “Tools” menu, you can adjust various additional features: 
 

Hover Delay: click this item to display a dialog where you can adjust the “hover” 
time delay. This is the time (in sec) before the folder below a “dragged” file is 
opened (expanded) automatically. A recommended range of values is between 0.5 
and 1.5 seconds. You can also choose from two AutoExpand folder options. Either 
a folder will automatically expand if you drop a file on it or if the hover timeout is 
exceeded, whichever happens first. The alternative is to autoexpand the folder only 
if the hover timeout is exceeded. This is a useful option if you do not wish to see 
the contents of a folder each time you drop something onto it. 
Background Color: this item will display a dialog for selecting background colors 
for icons as well as panels. 
Icon Layout: this item will allow you to adjust the display of icons in the middle 
panel (and in the print out) by choosing the number of icons per row and their 
relative separations. 
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File Filter: this item will allow you to choose which types of embroidery files – 
distinguished by their file extension – will appear in the center panel. For example, 
if you only want to view Brother (“pes” extension) type files when searching the 
directory folders, then use the File Filter dialog to select “pes”. 
 


